InCopy CC
Getting started with an InCopy CC workflow
1. Super-simple approach
InDesign CC preps the .indd file for InCopy to use
In Preferences > File Handling, the InDesign user sets the preference to allow for textfiles to show up in the Links
Panel. The InDesign CC user opens the InDesign file and exports some or all text content outside the document into
folders on the network. Now, all text files will be externally linked as .icml textfiles.

What the InCopy writer/editor does
The InCopy writer/editor clicks File > User to setup a user name and color key. The InCopy CC writer/editor next clicks
on File > Open and browses to the InDesign document and seemingly opens it. In actuality, the InCopy user is not
opening the .indd file; but rather is opening a copy of the whole multi-page layout. But, it looks the same as if you
opened the file in InDesign.
The InCopy writer/editor sees a story he or she would like to edit. After clicking the Type tool into the Story, the InCopy
user must Check Out the story for editing. This means that no one else can work on that checked-out story while he or
she is working on it. InCopy is editing the .icml textfile.
The InCopy user can look at the story in any of 3 different views: Galley, Story, or Layout view, where writing to fit can be
done visually. When done editing, he or she Saves Content, and then Checks-In the story, and can work on a new story
or close the document.

What the InDesign graphic designer does afterward
When the story is saved and checked back in by the InCopy writer/editor, the status of the .icml file will show as Out of
Date. The InDesign user looks at the Assignments panel and sees the story that has the yellow warning triangle. He or
she clicks Update and the text is relinked into the layout, giving the InDesign document the same text that the InCopy
user edited.

2. Still pretty simple approach: use assignments
InDesign CC preps the .indd file for InCopy to use
In Preferences > File Handling, the InDesign user sets the preference to allow for textfiles to show up in the Links
Panel. The InDesign CC user opens the InDesign file and exports some or all text content outside the document into
folders on the network. Now, all text files will be externally linked as .icml textfiles. The InDesign user also makes
Assignments within the Assignments panel. He or she gives story content to different assignments. Assignment files
are .icma files; they define the geometry of the page and present the .icml textfiles within the pages.

What the InCopy writer/editor does
The InCopy writer/editor clicks File > User to setup a user name and color key. The InCopy CC writer/editor next clicks
on File > Open and browses to the InDesign document’s Assignment sub-folder in search of .icma files. These files
imitate the page geometry of the InDesign document, and also contain within them the .icml textfiles for editing.
The InCopy writer/editor sees a .icml story he or she would like to edit. After clicking the Type tool into the Story, the
InCopy user must Check Out the story for editing. This means that no one else can work on that checked-out story while
he or she is working on it. InCopy is editing the .icml textfile.
The InCopy user can look at the story in any of 3 different views: Galley, Story, or Layout view, where writing to fit can be
done visually. When done with editing, he or she Saves Content, and then Checks-In the story, and can work on a new
story or close the .icma assignment document.

What the InDesign graphic designer does afterward
When the story is saved and checked back in by the InCopy writer/editor, the status of the .icml file will show as Out of
Date. The InDesign user looks at the Assignments panel and sees the story that has the yellow warning triangle. He or
she clicks Update and the text is relinked into the layout, giving the InDesign document the same text that the InCopy
user edited.
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Managed-file workflow examples
When you establish workflow management between InCopy and InDesign, writers and editors can compose,
rewrite, expand, and edit documents at the same time that designers prepare the layout. Common workflows
include managing files on a local server, sharing files via e-mail packages, or using some combination of the
two methods.
These workflows assume that you have a basic InDesign template with layout geometries, styles, and
placeholder text. Layout geometries include page dimensions as well as text and graphics frames. InCopy uses
these items to show proper copyfit information.

Local server workflow

1. In InDesign, create assignments and add content to them.
This step incorporates exported text and graphics frames into the managed process, where they become
available to InCopy users for writing and editing.
2. Make the assignment files available to InCopy users.
Save the files to a server that all workflow users have access to.
3. In InCopy, open the assignment file, and check out and edit a story or graphic.
In InCopy, the files containing content assigned to you appear in the Assignments panel. Whenever you
save the file on a local server, the changes are saved on the file system and anyone working on that
document (the InDesign layout or another managed content file in the document) receives notification of
the changes. Those users can update the content to view the latest changes. The content remains checked
out to you until you check it in.
4. In InDesign, work on the layout.
Regardless of whether the content files are being edited in InCopy, InDesign users can work on the
document layout; they don’t have to check out the document. Whenever the InCopy user saves the
checked-out content, the InDesign user can update that content within the layout to see the latest
revisions.
5. In InCopy, continue working.
When finished with your edits, check in the content. Other users are then able to check out the content and
work on it. If a user is modifying the layout in InDesign simultaneously, you can update and view the layout
geometry as you work.
6. In InDesign, make sure that all the content is checked in.
The managed workflow makes it possible to know who has checked out files. After content files are checked
in, InDesign users can check out the files to finalize the layout as necessary.
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E-mail package workflow

1. In InDesign, create and send assignment packages.
Create assignment packages and assign contents to the appropriate InCopy users, and then send the
packages to the InCopy users. The packaged files are automatically checked out to help avoid editing
conflicts.
2. In InCopy, open the assignment package, and check out and edit a story or graphic.
If you receive an assignment package in e-mail, double-click the package to open it in InCopy.
3. In InDesign, work on the layout.
Regardless of whether the content files are being edited in InCopy, InDesign users can work on the
document layout; they don’t have to check out the document. If you need to update the layout or
assignments, you can send an updated package to the InCopy users.
4. In InCopy, return the edited package.
When finished with your edits, check in the content and return the modified package. Other users are then
able to check out the content and work on it.
5. In InDesign, make sure that all the content is checked in.
The managed workflow makes it possible to know who has checked out files. After assignment packages
are returned, stories in assignment packages are checked in. InDesign users can check out the files to
finalize the layout as necessary.
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Workflow icons
Icons can appear on text and graphics frames, in the Links panel, the Assignments panel, and in the story bar
(InCopy only). Edit status icons appear next to the managed file in the Links panel and Assignments panel, and
communicate content status. Text frame icons appear on a text frame that contains a linked InCopy story (in
the Layout view in both InDesign and InCopy). These icons also communicate content status and can be used
to differentiate between managed and unmanaged content. The associated tool tip indicates editing status and
ownership. To view the text frame icons, make sure that frame edges are showing in InDesign and InCopy
(View > Show Frame Edges).
Note: (InDesign) The InDesign document window must be in Normal Mode for the frame edges to show. (Click
the Normal Mode button

Icon

at the lower left of the toolbox.)

Name

Location

Available

Links panel (InDesign), Assignments panel (InDesign and
InCopy), text frames, and graphics frames

In Use By [name]

Assignments panel, text frames, and graphics frames

Editing

Assignments panel, text frames, and graphics frames

Available And Out Of
Date

Text and graphics frames

In Use By name And
Out Of Date

Text and graphics frames

Editing And Out Of
Date

Text and graphics frames

Out Of Date

Assignments panel

Text Content Out Of
Date

Assignments panel and text frames

Text Content Up To
Date

Assignments panel and text frames

Graphics Content Out
Of Date

Assignments panel and graphics frames

Graphics Content Up To
Date

Assignments panel and graphics frames

Packaged Content

Assignments panel
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Best practices for working with managed files
Use the following practices to make sure that you work with the most up-to-date content and don’t overwrite
someone else’s work:
 Store assignment files on a server where all team members have access. If team members don’t have

access to a server, you can create and distribute assignment packages.
 When you create an assignment, a special folder is created to hold the assignment file and the content.

Use these assignment folders to maintain assignment and content files. They simplify managing the
shared files across a workgroup and help ensure that users open the correct files. If a file is moved from
one assignment to another, its content file is moved to that assignment's folder.
 In InCopy, open the assignment file instead of an individual InCopy story. That way, you can see the

copyfit and layout information in Galley and Layout views. If you export content without using assignment
files, you can see copyfit and layout information only by opening the InDesign file.
 As soon as you open an assignment file, open an InDesign document, or check out content in either

InDesign or InCopy, make sure that frame edges are showing (View > Show Frame Edges) so that you
can see the frame icons when they appear.
 In InDesign, if you must remove files from the workflow (because of a production deadline, for example),

you can unlink them or cancel an assignment package.
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Assignment files
In InDesign, assignment files are containers for organizing collections of page items. For example, you might
want to select all the items in a story (headline, byline, copy, graphics, and captions), and then assign them to
one InCopy user. Adding those items to an assignment provides a convenient way for InCopy users to access
only the content for which they are responsible. Assignment files (*.icma) appear in the file system, in the
InCopy story bar, and in status messages. Only InDesign users can create assignment files; only InCopy users
can open them.
When you create an assignment, a folder is created in the same location as the InDesign document by default.
This assignment folder includes the *.icma assignment files and a content subfolder that contains any exported
InCopy story files (in ICML format) that are part of images or other resources. Once the assignment is created,
store the project folder in a location where all users have access to it, or create and distribute an assignment
package. If content is exported before it’s added to an assignment, the files on disk are not moved to the
content folder of the assignment file.
Assignment files include the following:
 Links or pointers to the associated page items, including placeholder frames. These elements let the

InCopy user open a single file in InCopy and have editorial access to multiple page items.
 Any transformations on the graphics included in the assignment, such as moving, scaling, rotating, or

shearing.
 Page geometry, so InCopy users can see the layout of the frame and its content that they’re editing

without opening the entire InDesign file.
 Color-coding of assigned frames in the document.
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Assignments panel overview
The primary tool for working with assignments is the Assignments panel (Window > Assignments). The
Assignments panel displays the files exported from the currently active InDesign document, and an icon
indicates their status. The Assignments panel menu also contains commands that control import version and filemanagement functions between InCopy and InDesign. When you open an assignment in InCopy, the assignment
name and its contents appear in the Assignments panel. You can double-click text and graphics frames in the
Assignments panel to select them in the document window.

Note: All content exported to InCopy or added to an
assignment is also listed in the Links panel. Although you
can do some workflow management tasks, such as
checking out and checking in content, the recommended
panel for these tasks is the Assignments panel.

InDesign Assignments panel: A. InCopy content names B. InDesign document name C. Assignment Out Of
Date status D. Available And Graphic Up To Date status E. In Use And Text Out Of Date status F. Editing
And Text Up To Date status G. Unassigned content H. User name I. Update Content button J. Check Out/
Check In Selection button K. New Assignment button L. Delete Selected Assignments/Remove button

InCopy Assignments panel: A. InCopy content names B. Assignment name C. Assignment Out Of Date status
D. Available And Graphic Up To Date status E. In Use And Text Out Of Date status F. Editing And Text Up To
Date status G. Unassigned content H. User name I. Update Design button J. Update Content button K. Check
Out/Check In Selection button

