Adobe InDesign CS5 and CS4 and CS3
a tour of all 21 presets, styles, and automations
Deleting (aka trashing) Preferences
When InDesign is behaving erratically, and operating system and fonts don’t seem to be the
source of the problem, deleting (a.k.a. trashing) preferences often solves the problem. Here
is how to trash preferences as well as how to preserve preference settings:
[Mac OS X] While pressing Shift + Opt + Cmd + Ctrl, start InDesign. When asked if you want
to delete the preference files, Click Yes
[Win XP and Vista and Windows 7] While pressing Shift + Ctrl + Alt, start InDesign. When
asked if you want to delete the preference files, Click Yes
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This action deletes two files: InDesign Defaults and InDesign SavedData. To search for these
files, make sure you search also in Hidden and System files, otherwise, they won’t show. You
can delete these two files manually, instead of holding down the key combination at start of
program. Afterward, once InDesign is restarted, factory-default versions of these two files
are regenerated and put to work.
Open Recent list will be lost when you reset preferences. There is no work-around. And
unless these are manually saved; Document Presets, Transparency Flattener Presets, Stroke
Styles, and Print Presets will be lost when you trash preferences.
Note: This report was edited and rewritten for InDesign CS5 where the main folder is
Version 7.0/en_US. If you are using InDesign CS4, refer to the Version 6.0/en_us folder. If
you are using CS3, go to the Version 5.0 folder which does not have a language sub-folder.

Workspaces Presets
Window > Workspace > New Workspace is for remembering the position of InDesign CS4’s
45 panels, along with any menu customizations you make. Workspace presets are .xml files.
[Mac OS] Mac/Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US/Workspaces
[Win XP] C:\Documents and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Workspaces
[Win 7/Vista] Users\Username\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\Workspaces

Menu Customization Presets
Edit > Menus. You cannot edit the default set. Click Save As and type a name for the new
menu set, and click OK. From the Category menu, choose Application Menus or Context
& Panel Menus. Click the eye icon to hide or show the command; click to select a color
code. Click Save, and OK. Hiding doesn’t disable any features. Show All Menu Items is at the
bottom of the menu; or you can Ctrl/Cmd click the menu to see all. Menu sets are saved as
.inms files.
[Mac OS] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US/Menu Sets
[Win XP] C:\Documents and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Menu Sets
[Win 7/Vista] Users\Username\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\Menu Sets
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Open Recent List
File > Open Recent shows a list of the most recently opened and edited documents
worked on within InDesign. This same Open Recent list is also available on the Help menu
> Welcome Screen, something that comes up on the screen on its own whenever a file is
closed out, unless the don’t show again checkbox is checked.
The Open Recent list is lost when you reset preferences, and there is no way to preserve it
nor back-up the information.

Document Presets
File > Document Presets > Define… New… To skip the New Document dialog box, press the
Shift key as you select a preset from the Document Preset menu. These can then be saved,
loaded, and shared. Their location can be anywhere on your hard drive, and they have a
.dcst filename extension. If not manually saved, they are lost when you trash preferences.
Suggestion: make a new Document Presets folder for these document presets under the
Version 7.0/en_US folder where the other presets are stored, like this:
[Mac OS] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US/Document Presets
[Win XP] C:\Documents and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Document Presets
[Win 7/Vista] Users\UserName\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\Document Presets
Suggestion: Use this Document Presets folder to store custom-made document presets; and back up the whole Version 7.0\
en_US folder (or the Version 5.0 folder, if in CS3) and subfolders that are full of your various presets.

Autocorrect Presets
InDesign menu > Preferences (Mac) or Edit > Preferences (Win) > Autocorrect > Add… is for
adding your own misspellings corrections. Autocorrect in preferences allows you to correct
spelling as you type, being triggered as you press the spacebar to move on to the next word.
Commonly-typed errors and capitalization errors can both be corrected as you type. This
feature could also be utilized for repetitive, long web and email addresses. Any additions are
saved as an .xml file here:
[Mac OS] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US/Autocorrect
[Win XP] C:\Documents and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Autocorrect
[Win 7/Vista] Users\UserName\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\Autocorrect
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InDesign Shortcut Presets
Edit > Keyboard Shortcuts. Click the button labeled New Set. Type a name for the new set,
choose a Based On Set, and click OK. If you want to read and print a list of shortcuts, choose
Show Set. This produces a textfile. Suggestion: Do not edit the Default shortcut set; rather,
always create and edit a new set based on the default set. Shortcuts can be assigned in the
context of Default, Table, or Text. This allows one shortcut to have three contextual uses.
Shortcut sets are .indk file extensions and are located here, automatically:
[Mac OS] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US/InDesign Shortcut Sets
[Win XP] C:\Documents and Settings\UserName\App Data\Adobe\InDesign\Version 7.0\en_US\InDesign Shortcut Sets
[Win 7/Vista] Users\UserName\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\InDesign Shortcut Sets

Stroke Styles
Stroke panel menu button > Stroke Styles > New. You create a custom stroke style that can
be dashed, dotted, or striped. You define the stroke’s pattern, cap, and corner attributes. You
specify other stroke attributes, such as weight, gap color, and start and end shapes, after the
stroke style has been applied to an object. While in Stroke Styles, choose your style and then
click Save. Specify a name and location and click OK. This creates an external .lnst filename
extension. Suggestion: make a new Stroke Styles folder for these stroke style presets under
the Version 7.0/en_US folder, the same folder where all the other presets are stored:
[Mac OS] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US/Stroke Styles
[Win XP] C:\Documents and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Stroke Styles
[Win 7/Vista] Users\UserName\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\Stroke Styles
Suggestion: Use this Stroke Styles folder to store custom-made stroke styles; and back up the whole Version 7.0/en_US folder (or
the Version 5.0 folder, if in CS3) along with its subfolders that are full of your various presets.

Adobe Swatch Exchange
These swatches can be used in Photoshop and Illustrator. Swatches panel menu button >
Save Swatches. Choose a name and location and click Save. This creates an Adobe Swatch
Exchange file with an .ase filename extension. Suggestion: make a new folder named Swatch
Exchange for these Swatch presets under the Version 7.0/en_US folder, where all your other
presets are stored:
[Mac OS] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US/Swatch Exchange
[Win XP] C:\Documents and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Swatch Exchange
[Win 7/Vista] Users\UserName\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\Swatch Exchange
Suggestion: Use this Swatch Exchange folder to store custom-made ASE files; and back up the whole Version 7.0/en_US folder (or
the Version 5.0 folder, if in CS3) along with the many subfolders that are full of various presets.
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Word Doc or RTF File Import Options Presets
File > Place a Word or RTF file; with Show Import Options selected, and choose to Open the
text document. In the Import Options dialog box, specify settings. Click Save Preset, type a
preset name, and click OK. Optionally, click Set As Default to use the preset each time you
import a file of that filetype. This was buggy in CS4 until you patched to 6.0.4.
Word import presets have a .smp filename, and are automatically stored here:
[Mac OS] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US / Word Import Presets
[Win XP] C:\Docs and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Word Import Presets
[Win 7/Vista] Users\UserName\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\Word Import Presets

RTF file presets have a .smp filename, and are automatically stored here:
[Mac OS] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US / RTF Import Presets
[Win XP] C:\Docs and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\RTF Import Presets
[Win 7/Vista] Users\UserName\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\RTF Import Presets

Glyph Sets Presets
Type > Glyphs > Glyphs panel menu button > New glyph set. Name the set. Choose the
insert order. This named collection of glyphs can come from one or more fonts. Custom
glyph sets are stored in sharable files kept in the Glyph Sets folder. They do not have a filename extension. To add a glyph to a set, select the font and glyph; then click the Glyphs
panel menu button and choose Add to Glyph Set (and the name of your custom glyph set).
[Mac OS] Users/Username/Library/Preferences/Adobe InDesign/Version 7.0/en_US/Glyph Sets
[Win XP] C:\Documents and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Glyph Sets
[Win 7/Vista] Users\Username\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\Glyph Sets

Table of Contents Style Presets
Layout > Table of Contents Styles. Click New… Type a name for the TOC style preset you are
creating. A ToC style remembers all the settings for generating and formatting a table of
contents. To define a ToC style that contains the formatting and other options for your ToC,
click the Save Style button. You cannot save a ToC style preset external to the document;
but you can load and share ToC style presets from document to document. Remember to
create ToC paragraph styles in the Paragraph Styles panel before you setup the Table of
Contents styles. You might also need to develop Character Styles prior to defining the ToC
Style preset.
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Find/Change Text Queries Presets
Edit > Find/Change. A text query is a defined and recorded find-and-change operation in
the Text tab. Save a query in the Find/Change dialog box if you want to run it again or share
it with others. This creates .xml files automatically located here:
[Mac OS] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US/Find-Change Queries/Text
[Win XP] C:\Documents and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Find-Change Queries\Text
[Win 7/Vista] Users\UserName\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\ Find-Change Queries\Text

Find/Change GREP Queries Presets
Edit > Find/Change. A GREP query is a defined and recorded find-and-change operation in
the GREP tab. Save a query in the Find/Change dialog box if you want to run it again or share
it with others. This creates .xml files automatically located here:
[Mac OS] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US/ Find-Change Queries/GREP
[Win XP] C:\Documents and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Find-Change Queries\GREP
[Win 7/Vista] Users\UserName\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\ Find-Change Queries\GREP

Find/Change Object Queries Presets
Edit > Find/Change. An object query is a defined and recorded find-and-change operation
in the Object tab. Save a query in the Find/Change dialog box if you want to run it again or
share it with others. This creates .xml files automatically located here:
[Mac OS] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US/ Find-Change Queries/Object
[Win XP] C:\Docs and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Find-Change Queries\Object
[Win 7/Vista] Users\UserName\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\ Find-Change Queries\Object

Find/Change Glyph Queries Presets
Edit > Find/Change. A Glyph query is a defined and recorded find-and-change operation
in the Glyph tab. Save a query in the Find/Change dialog box if you want to run it again or
share it with others. This creates .xml files automatically located here:
[Mac OS] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US/ Find-Change Queries/Glyph
[Win XP] C:\Doc and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Find-Change Queries\Glyph
[Win 7/Vista] Users\UserName\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\ Find-Change Queries\Glyph
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Tagging Presets
When you select a text frame, table, cells, or an image, and then click Tags panel menu
button flyout > Autotag command, InDesign applies a default xml tag to the item you
selected. You can specify these default tags in the Tags panel menu > Tagging Preset
Options dialog box. Choose your default tag for text frames, tables, cells, and images. If
you don’t already have the tag you need to use, choose New Tag from the menu to create a
new xml tag. Choose Tags panel menu button > Save Tags, where you can name and save
the tags as an .xml file that can be used in another xml-aware program or another InDesign
document.

Transparency Flattener Presets
Edit > Transparency Flattener Presets > New… You can save, load, and share transparency
flattener presets as a separate file. Transparency flattener preset files have an .flst extension. Their location is wherever you save it to. If not manually saved, they are lost when
you trash preferences. You can’t edit the default flattener presets. Suggestion: make a new
Transparency Flattener Presets folder for these transparency flattener presets under the
Version 7.0/en_US folder:
[Mac] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US/Transparency Flattener Presets
[Win XP] C:\Docs and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Transparency Flattener Presets
[Win 7/Vista] Users\UserName\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\Transparency Flattener Presets
Suggestion: Use this folder to store custom-made transparency flattener presets; and back up the whole Version 7.0/en_US
folder (or the Version 5.0 folder, if in CS3) along with its subfolders full of your various presets.

Export to PDF Presets
These built-in presets for generating PDFs are the same as joboptions, and are named with
the .joboptions file name extension. These are not destroyed when you reset preferences.
The pre-installed joboptions are stored here:
[Mac OS] Mac/Library/Application Support/Adobe/Adobe PDF/Settings
[Win] C:\Documents and Settings\All Users\Application Data\Adobe\Adobe PDF\Settings
[Win 7/Vista] Users\All Users\Adobe\Adobe PDF\Settings and also look here ProgramData\Adobe\Adobe PDF\Settings

In CS4 and CS3, the nearby Extras folder (for example: c:\Documents and Settings\All Users\
Application Data\Adobe\Adobe PDF\Extras) contains additional presets that can be used
if you move these presets into the Settings folder. You can also make your own new joboptions. New, custom joboptions that you have created are stored here:
[Mac OS] Users/UserName/Library/Application Support/Adobe/Adobe PDF/Settings
[Win] C:\Documents and Settings\UserName\Application Data\Adobe\Adobe PDF\Settings
[Win 7/Vista] Users\Username\AppData\Roaming\Adobe\Adobe PDF\Settings
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Print Presets
File > Print, adjust print settings, and click Save Preset. The preset is saved in the InDesign
Defaults file only. A better way: File > Print Presets > Define... and then click Save. Use the
default name, Saved Print Presets, and then click Save to return to the Print Presets dialog
box. Then click OK again. If not manually saved with these extra steps, they are lost when
you trash preferences. Print presets are .prst filename extensions. Suggestion: make a new
Print Presets folder for these print presets under the Version 7.0/en_US folder, along with
other presets:
[Mac OS] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US/Presets\Print Presets
[Win XP] C:\Documents and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Print Presets
[Win 7/Vista] Users\UserName\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\Print Presets
Suggestion: Use this new Print Presets folder to store all your custom-made print presets; and back up the whole Version 7.0/
en_US folder (or the Version 6.0 folder, if in CS4) and subfolders full of your various presets.

Trapping Presets
Window > Output > Trap Presets panel. A trap preset is a collection of trapping settings you
can apply to a page or range of pages for defining the amount of compensation for misregistration on press. The trap presets panel provides for entering and saving trap settings. You
cannot save a trap preset external to the document; but you can load and share trap presets
from document to document. Trap presets do not get removed when you reset preferences
and restart the InDesign application.

Preflight Presets
Window > Output > Preflight. (new in CS4) The Preflight panel warns of output/imaging
problems including missing files or fonts, low-resolution images, overset text, too-small
stroke widths, and other conditions you can configure it to detect. These preflight rules can
exist only within the document, or can be stored in sharable profiles with a .idpp filename
ending. If Preflight is turned on, a red dot icon appears in the status bar when InDesign
detects any violations. Open the Preflight panel Info section to get guidance for fixing them.
To make or load a .idpp preflight profile, click on Preflight panel menu button flyout > Define
Profiles. Choose the preflight rules you want from within the middle right portion of the
dialog box; then click the lower-left plus (+) sign to save a named profile. Near the bottom
left of the Preflight Profiles dialog box, click the small panel menu button and choose Load,
Export, or Unembed a .idpp profile. Suggestion: make a new Preflight Presets folder for
these Preflight presets under the Version 7.0\en_US folder:
[Mac] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US/Preflight Presets
[Win XP] C:\Docs and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Preflight Presets
[Win 7/Vista] Users\UserName\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\Preflight Presets
Suggestion: Use this folder to store custom-made Preflight presets; and back up the whole Version 7.0\en_US folder along with
its subfolders full of your various presets.

InDesign CS5 | CS4 | CS3 presets | styles | automations

http://trainingonsite.com 7

InDesign JavaScripts for automation and speed
Scripting is a tool for performing many tasks more quickly. Scripting can drive a common
task or can be more elaborate; resembling a plug-in. Scripts can be written in JavaScript
script language (which is cross-platform and preferred), AppleScript (Mac only), and VBScript
(Windows only). You can create your own scripts, but it is easier to run scripts others have
created. They are easily copied and pasted into any text editor and saved with a .jsx filename
extension. Install your JavaScripts here:
[Mac OS] Users/UserName/Library/Preferences/Adobe InDesign/Version 7.0/en_US/Scripts/Scripts Panel
[Win XP] C:\Documents and Settings\UserName\Application Data\Adobe\InDesign\Version 7.0\en_US\Scripts\Scripts Panel
[Win 7/Vista] Users\UserName\AppData\Roaming\Adobe\InDesign\Version 7.0\en_US\Scripts\Scripts Panel

If you have a CS4 script, put it into a folder named Version 6.0 Scripts. If you have
a CS3 script, put it into a folder named Version 5.0 Scripts. If you have a CS2 script,
install it in a folder named Version 4.0 Scripts. If you have a CS script, put it in a
folder named Version 3.0 Scripts. (There are very few changes in the way scripts are
handled between CS3 and CS5, so many of your CS3 scripts will run in CS4 or CS5
without these specially-named folders.) These script folders are all put under the
Scripts Panel folder.
Here are some JavaScript scripting resources:
Adobe InDesign Scripting User to User Forum: http://forums.adobe.com/community/indesign/indesign_scripting
Adobe Scripting reference: http://www.adobe.com/products/indesign/scripting/pdfs/InDesignCS5_ScriptingGuide_JS.pdf
JavaScript Tools Guide: http://www.adobe.com/products/indesign/scripting/pdfs/JavaScriptToolsGuide_CS5.pdf
Adobe Studio Exchange: http://www.adobe.com/cfusion/exchange/index.cfm
Introduction to Scripting: http://www.adobe.com/products/indesign/scripting/pdfs/adobe_intro_to_scripting.pdf
PDS Associates site: http://www.pdsassoc.com/index.php?Nav=downs&Ban=Downloads&Info=downloads.html
Peter Kahrel’s script launcher utility: http://www.kahrel.plus.com/indesignscripts.html
Peter Kahrel’s object properties lookup: http://www.kahrel.plus.com/indesign/id5-dict.html
Teus DeJong’s Object Browser (click to the InDesign Utilities, pc version only): http://www.teusdejong.nl
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